Hi,

I've followed the tutorial to install ikiwiki. Once installed (on a Ubuntu 10.04 distro running under VirtualBox on a Windows XP, SP3 host), I can access the http://ubuntu1004/index.lighttpd.html page without any issues.

But when I try to access the page http://ubuntu1004/~geertvc/gwiki (as is mentioned at the end of the ikiwiki setup), I get the error message "404 - not found".

I've also followed the "dot-cgi" trick, but with the same negative result. The web server I've installed, is lighttpd.

What did I miss?

Best rgds,

--Geert

Perhaps your webserver is not exporting your public_html directory in ~geertvc? Check its configuration. --Joey

You probably need to run "lighttpd-enable-mod userdir"
Comment by jmtd [livejournal.com] Thu Sep 9 17:41:07 2010

After a re-installation of ikiwiki (first removed all old files), I get the following feedback:

Successfully set up gwiki:
    url:         http://ubuntu1004/~geertvc/gwiki
    srcdir:      ~/gwiki
    destdir:     ~/public_html/gwiki
    repository:  ~/gwiki.git
To modify settings, edit ~/gwiki.setup and then run:
    ikiwiki -setup ~/gwiki.setup

In the lighttpd config file (/etc/lighttpd/lighttpd.conf), I've now changed the item "server.document-root" from the default "/var/www" to (in my case) "/home/geertvc/public_html/gwiki". I've taken the destdir location (see above) as document root for lighttpd.

When doing this, I can see the "index.html" page of ikiwiki (by typing the following URL in the address box of the browser: "ubuntu1004/index.html"). So, that seems to be the right modification, right? Or isn't it?

Note: when I take the directory "/home/geertvc/gwiki" (= the URL given above), then things do not work. I can't see the content of "index.html", I get the error message I mentioned in my initial post (404 - not found).

But when clicking, for instance, the "Edit" button, the link brings me to the following location:

http://ubuntu1004/~geertvc/gwiki/ikiwiki.cgi?page=index&do=edit

However, there's not at all a file called "ikiwiki.cgi" at that location. The location of the file "ikiwiki.cgi" is "/home/geertvc/public_html/gwiki", so why is the link "Edit" leading me to that (wrong?) location?

Apparently, something is still wrong with my settings. Hope, with the above information, someone can put me on the right track...

Comment by Geert Sun Sep 12 02:45:27 2010
Please re-read my comment. If you enable usersdirs then /~user corresponds to ~/public_html. The change you have made has / corresponding instead, which is why the links don't work.
Comment by jmtd [livejournal.com] Sun Sep 12 08:26:49 2010