Dot CGI pointing to localhost. What happened?

My ikiwiki broke. For some reason ikiwiki.cgi started pointing to https://localhost:80/ instead of the real URL. Can somebody help me find out why this has happened and perhaps fix it? Now login and recentchanges do not work because of it.

I believe the change happened after my hosting provider upgraded their server OS from Debian oldstable to stable. Rebuilding the .cgi or the wiki hasn't helped nor has helpdesk been helpful. Any hints as to debug this are appreciated.

Thanks!

The CGI automatically builds self-referential URLs based on how you accessed it, so if your web host puts it behind a reverse proxy or something, that might make it try to redirect to localhost?

If that's it, then $q->url with $params{cgiurl} in IkiWiki/CGI.pm and IkiWiki/Plugin/openid.pm would work around it.

Comment by smcv Fri Nov 22 05:03:38 2013

I have added a new $config{reverse_proxy} option in git master which applies the necessary hard-coding.

Also in git master, if $config{html5} = 1 then the <base> URL will usually be host-relative or protocol-relative (/wiki/ or //example.com/wiki/) which reduces the need for that option.

These are not yet available in a release, and are still subject to change.

Comment by smcv Sun Oct 5 18:55:01 2014